Disruption delivering to Yahoo email services

Incident Report for Sine

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2026 - 14:34 ACST

Investigating

We are currently experiencing issues delivering email to Yahoo services. We will update as we have more information.
Posted May 22, 2026 - 09:31 ACST